De ce este vulnerabil un website pe platformă WordPress neactualizată

Platforma WordPress este o soluție optimă pentru realizarea și întreținerea unui website, cu multe beneficii, dar îl și poate pune în pericol dacă aceasta și pluginurile utilizate nu sunt actualizate la zi.

Chiar dacă sunt câțiva ani de când WordPress a acaparat piața de webdesign, în detrimentul unor platforme realizate de către diverse echipe mai mult sau puțin stabile pe piață, website-urile realizate pe această platformă sunt confundate de către unii administratori cu website-urile din generațiile anterioare care puteau supravețui chiar dacă erau ignorate complet o perioadă de timp. Un website care folosește o versiune WordPress veche sau versiuni învechite ale unor pluginuri este un website vulnerabil – poate pierde în orice moment întregul conținut: themă, arhivă și bază de date.

Atacurile online evoluează într-un ritm alert, ritm care impune o adaptare rapidă a măsurilor de securitate a platformei WordPress și a pluginurilor, în special a celor de securitate. Părerile despre momentul în care să se efectueze aceste actualizări sunt împărțite. Unii specialiști în domeniu sunt adepții actualizărilor automate imediat ce apare o versiune nouă. Alții recomandă o prudență de câteva zile sau testarea lor inițială pe un proiect secundar pentru a se evita blocarea website-ului din cauza unor posibile erori de programare. Din păcate, în practică sunt întâlnite frecvent website-uri cu versiuni foarte vechi. Întârzierile nu sunt de câteva zile. Am întâlnit versiuni vechi și de câțiva ani.

În cazul website-urilor mai complexe care operează cu date cu caracter personal riscul asumat de către administrator este și mai mare. Conform normelor GDPR el are obligația de a lua toate măsurile care se impun pentru a împiedica furtul informațiilor respective. Neactualizarea platformei wordpress și a pluginurilor de securitate utilizate este considerată o nerespectare a acestor obligații.

Contractul de hosting / de găzduire web nu prevede și obligații privind actualizările pentru website indiferent de platforma utilizată. Aceste obligații sunt exclusiv în sarcina administratorului de website sau fac obiectul unui contract separat de mentenanță. Măsurile de securitate online existente pe server nu sunt suficiente pentru a proteja un website realizat pe platformă WordPress deoarece atacurile pot viza direct anumite fișiere vulnerabile ale acestei platforme.

webdesign vrancea
Maux Design Focșani

Noi te putem ajuta să-ți îmbunătățești identitatea vizuală și să-ți crești vânzările în mediul online.

Website: www.mauxdesign.com

Arhivă editor:
vrancea
vrancea
vrancea
vrancea
© Vrancea.com.ro